summaryrefslogtreecommitdiff
path: root/dev-python/pycryptodomex/pycryptodomex-3.8.2.ebuild
diff options
context:
space:
mode:
authorCtibor Brančík <ctibor@brancik.cz>2019-09-24 09:28:51 +0200
committerCtibor Brančík <ctibor@brancik.cz>2019-09-24 09:28:51 +0200
commit690afaeeb0cf55e4a23c39630988bfe104d3f97a (patch)
treef08b45c2ce737e1f553b43275c1e35b2c5e74e99 /dev-python/pycryptodomex/pycryptodomex-3.8.2.ebuild
parentde5c0bfa12391efee3ddb73a4655f34729772d32 (diff)
parent399ba82488ca397d19cb98eb5319e3482a81bef2 (diff)
downloadbrancik-overlay-690afaeeb0cf55e4a23c39630988bfe104d3f97a.tar.gz
brancik-overlay-690afaeeb0cf55e4a23c39630988bfe104d3f97a.tar.bz2
Merge branch 'master' of ssh://git.brancik.cz/brancik-overlay
Diffstat (limited to 'dev-python/pycryptodomex/pycryptodomex-3.8.2.ebuild')
-rw-r--r--dev-python/pycryptodomex/pycryptodomex-3.8.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pycryptodomex/pycryptodomex-3.8.2.ebuild b/dev-python/pycryptodomex/pycryptodomex-3.8.2.ebuild
new file mode 100644
index 0000000..c5a3d62
--- /dev/null
+++ b/dev-python/pycryptodomex/pycryptodomex-3.8.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A self-contained cryptographic library for Python"
+HOMEPAGE="https://www.pycryptodome.org https://github.com/Legrandin/pycryptodome https://pypi.org/project/pycryptodome/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2 Unlicense"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~ppc-aix ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-libs/gmp:0
+ virtual/python-cffi[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}