summaryrefslogtreecommitdiff
path: root/sci-libs/libinova/libinova-1.7.2.ebuild
diff options
context:
space:
mode:
authorCtibor Brančík <ctibor@brancik.cz>2018-07-20 14:01:09 +0200
committerCtibor Brančík <ctibor@brancik.cz>2018-07-20 14:01:09 +0200
commit3940f9d811b8f877447245591ee5c5c815409bb9 (patch)
treeb88dcf327396a4a500321654ad5fd85d3b7a4793 /sci-libs/libinova/libinova-1.7.2.ebuild
parenta5f5a3603ca75436a6cf4c2a42d2ab0cf59e464f (diff)
downloadbrancik-overlay-3940f9d811b8f877447245591ee5c5c815409bb9.tar.gz
brancik-overlay-3940f9d811b8f877447245591ee5c5c815409bb9.tar.bz2
Update indilib to v1.7.2
Diffstat (limited to 'sci-libs/libinova/libinova-1.7.2.ebuild')
-rw-r--r--sci-libs/libinova/libinova-1.7.2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sci-libs/libinova/libinova-1.7.2.ebuild b/sci-libs/libinova/libinova-1.7.2.ebuild
new file mode 100644
index 0000000..1330b64
--- /dev/null
+++ b/sci-libs/libinova/libinova-1.7.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils eutils
+
+MY_PN="indi"
+
+DESCRIPTION="SDK and firmware for the i.Nova PLx series CCD/CMOS cameras"
+HOMEPAGE="http://indilib.org"
+SRC_URI="https://github.com/${MY_PN}lib/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_PN}lib-${PV}.tar.gz"
+
+LICENSE="inova"
+KEYWORDS="~amd64 ~x86 ~arm"
+
+SLOT="0"
+
+INDI_TARGET_DIRECTORY="${PN%%lib-driver-**}"
+
+S="${WORKDIR}/${MY_PN}-${PV}/3rdparty/${INDI_TARGET_DIRECTORY}sdk"