summaryrefslogtreecommitdiff
path: root/sci-libs/indilib-driver-qhy/indilib-driver-qhy-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/indilib-driver-qhy/indilib-driver-qhy-9999.ebuild')
-rw-r--r--sci-libs/indilib-driver-qhy/indilib-driver-qhy-9999.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/sci-libs/indilib-driver-qhy/indilib-driver-qhy-9999.ebuild b/sci-libs/indilib-driver-qhy/indilib-driver-qhy-9999.ebuild
index 07e874a..420a67f 100644
--- a/sci-libs/indilib-driver-qhy/indilib-driver-qhy-9999.ebuild
+++ b/sci-libs/indilib-driver-qhy/indilib-driver-qhy-9999.ebuild
@@ -1,16 +1,14 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
EAPI=5
-inherit cmake-utils git-2 eutils toolchain-funcs
+inherit cmake-utils git-r3 eutils toolchain-funcs
DESCRIPTION="INDI driver the for QHY CCD cameras"
HOMEPAGE="http://indilib.org"
EGIT_REPO_URI="https://github.com/indilib/indi.git"
-EGIT_PROJECT="indilib"
-EGIT_SOURCEDIR="${WORKDIR}/${P}"
+EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
LICENSE="LGPL-2 GPL-3 qhyccd"
KEYWORDS=""
@@ -18,21 +16,21 @@ KEYWORDS=""
SLOT="0"
DEPEND="=sci-libs/indilib-9999
- =sci-libs/libqhy-9999"
+ =sci-libs/libqhy-9999"
RDEPEND="${DEPEND}"
INDI_GIT_DIR="${PN%%lib-driver-*}${PN##*-driver}"
-S="${EGIT_SOURCEDIR}/3rdparty/${INDI_GIT_DIR}"
+S="${EGIT_CHECKOUT_DIR}/3rdparty/${INDI_GIT_DIR}"
pkg_pretend() {
- if [[ $(gcc-major-version) < 5 ]]; then
- eerror "You need to activate GCC 5 in order to compile this driver."
- eerror "This is because the binary included in sci-libs/libqhy has been built"
- eerror "with GCC 5. You need to install and activate sys-devel/gcc-5*"
- eerror "Please refer onto https://wiki.gentoo.org/wiki/Upgrading_GCC "
- eerror "for complete Gentoo GCC upgrading guide."
- die "GCC 5 is needed to build this package!"
- fi
+ if [[ $(gcc-major-version) < 5 ]]; then
+ eerror "You need to activate GCC 5 in order to compile this driver."
+ eerror "This is because the binary included in sci-libs/libqhy has been built"
+ eerror "with GCC 5. You need to install and activate sys-devel/gcc-5*"
+ eerror "Please refer onto https://wiki.gentoo.org/wiki/Upgrading_GCC "
+ eerror "for complete Gentoo GCC upgrading guide."
+ die "GCC 5 is needed to build this package!"
+ fi
}