summaryrefslogtreecommitdiff
path: root/sci-libs/indilib/indilib-1.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/indilib/indilib-1.4.1.ebuild')
-rw-r--r--sci-libs/indilib/indilib-1.4.1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/sci-libs/indilib/indilib-1.4.1.ebuild b/sci-libs/indilib/indilib-1.4.1.ebuild
deleted file mode 100644
index 6234695..0000000
--- a/sci-libs/indilib/indilib-1.4.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-MY_PN="${PN/lib/}"
-
-inherit cmake-utils udev user
-
-DESCRIPTION="INDI Astronomical Control Protocol library"
-HOMEPAGE="http://www.indilib.org/"
-SRC_URI="https://github.com/${PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${PN}-${PV}.tar.gz"
-
-LICENSE="LGPL-2.1+ BSD GPL-2+ LGPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="drivers qt5"
-
-RDEPEND="
- sci-libs/cfitsio
- sci-libs/libnova
- sci-libs/gsl
- sys-libs/zlib
- virtual/jpeg:0
- virtual/libusb:1
- net-misc/curl
- qt5? ( >=dev-qt/qtnetwork-5.6.2 )
-"
-DEPEND="${RDEPEND}
- sys-kernel/linux-headers
- drivers? ( sci-libs/indilib-drivers )
-"
-
-DOCS=( AUTHORS ChangeLog README TODO )
-
-S=${WORKDIR}/${MY_PN}-${PV}/libindi
-
-src_configure() {
- local mycmakeargs=(
- -DUDEVRULES_INSTALL_DIR=$(get_udevdir)/rules.d
- $(cmake-utils_use qt5 INDI_BUILD_QT5_CLIENT)
- )
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- newinitd "${FILESDIR}/indiserver.sh" indiserver
- newconfd "${FILESDIR}/indiserver.conf" indiserver
-}
-
-pkg_postinst() {
- enewuser indiserver -1 -1 -1 "usb,uucp,video" -U
- elog "You can use init script in /etc/init.d/indiserver to start"
- elog "indiserver automatically."
- elog "Configuration is in /etc/conf.d/indiserver."
-}
-