summaryrefslogtreecommitdiff
path: root/sci-libs/libapogee/libapogee-1.7.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libapogee/libapogee-1.7.5.ebuild')
-rw-r--r--sci-libs/libapogee/libapogee-1.7.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-libs/libapogee/libapogee-1.7.5.ebuild b/sci-libs/libapogee/libapogee-1.7.5.ebuild
new file mode 100644
index 0000000..005d89d
--- /dev/null
+++ b/sci-libs/libapogee/libapogee-1.7.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils eutils
+
+MY_PN="indi"
+
+DESCRIPTION="Driver for the Apogee ALTA device drivers"
+HOMEPAGE="http://indilib.org"
+SRC_URI="https://github.com/${MY_PN}lib/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_PN}lib-${PV}.tar.gz"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86 ~arm"
+
+SLOT="0"
+
+DEPEND="virtual/libusb:1
+ net-misc/curl"
+
+RDEPEND="${DEPEND}"
+
+INDI_TARGET_DIRECTORY="${PN%%lib-driver-**}"
+
+S="${WORKDIR}/${MY_PN}-${PV}/3rdparty/${INDI_TARGET_DIRECTORY}"