summaryrefslogtreecommitdiff
path: root/sci-libs/libinova/libinova-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libinova/libinova-9999.ebuild')
-rw-r--r--sci-libs/libinova/libinova-9999.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sci-libs/libinova/libinova-9999.ebuild b/sci-libs/libinova/libinova-9999.ebuild
new file mode 100644
index 0000000..4fcf7e3
--- /dev/null
+++ b/sci-libs/libinova/libinova-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils git-r3 eutils
+
+DESCRIPTION="SDK and firmware for the i.Nova PLx series CCD/CMOS cameras"
+HOMEPAGE="http://indilib.org"
+EGIT_REPO_URI="https://github.com/indilib/indi.git"
+EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
+
+LICENSE="inova"
+KEYWORDS=""
+
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/libinova-9999_fix_cmake_symlinks.patch" )
+
+S="${EGIT_CHECKOUT_DIR}/3rdparty/${PN}sdk"