summaryrefslogtreecommitdiff
path: root/app-crypt/acos5/acos5-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/acos5/acos5-9999.ebuild')
-rw-r--r--app-crypt/acos5/acos5-9999.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/app-crypt/acos5/acos5-9999.ebuild b/app-crypt/acos5/acos5-9999.ebuild
deleted file mode 100644
index d2d1040..0000000
--- a/app-crypt/acos5/acos5-9999.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CRATES="cfg-if-1.0.0
- libc-0.2.107
- num-integer-0.1.44
- pkg-config-0.3.22
- num-traits-0.2.14
- autocfg-1.0.1
- libloading-0.7.2
- winapi-0.3.9
- winapi-i686-pc-windows-gnu-0.4.0
- winapi-x86_64-pc-windows-gnu-0.4.0"
-
-inherit cargo git-r3
-
-DESCRIPTION="Driver for Advanced Card Systems (ACS) ACOS5 Smart Card"
-HOMEPAGE="https://github.com/carblue/acos5"
-SRC_URI="$(cargo_crate_uris)"
-EGIT_REPO_URI="https://github.com/carblue/acos5.git"
-
-LICENSE="LGPL-2.1"
-
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="dev-libs/opensc
- dev-libs/openssl
- sys-apps/pcsc-lite
- dev-libs/libtasn1"
-
-RDEPEND="${DEPEND}
- sys-apps/pcsc-tools"
-
-src_unpack() {
- git-r3_fetch
- git-r3_checkout
- cargo_src_unpack
-}
-
-src_configure() {
- cargo_src_configure
-}
-
-src_compile() {
- cargo_src_compile
-}
-
-src_install() {
- dolib.so "${S}/target/release/libacos5_pkcs15.so"
- dolib.so "${S}/target/release/libacos5.so"
- insinto /usr/share/opensc
- doins "${S}/acos5_pkcs15/acos5_external.profile"
- }