summaryrefslogtreecommitdiff
path: root/app-crypt/eobcanka/eobcanka-3.5.0.ebuild
diff options
context:
space:
mode:
authorCtibor Brančík <ctibor@brancik.cz>2025-04-22 11:17:30 +0200
committerCtibor Brančík <ctibor@brancik.cz>2025-04-22 11:17:30 +0200
commitc40a6a0e090d182eafb61c505f2a43df1a337bde (patch)
treec5dfe20be7df2b9d853d81db17f5436a5ecc5927 /app-crypt/eobcanka/eobcanka-3.5.0.ebuild
parent56137c483d5c7f3730b9f74c3b1b072a906a97e0 (diff)
downloadbrancik-overlay-master.tar.gz
brancik-overlay-master.tar.bz2
Bump app-crypt/eobcanka to 3.5.0HEADmaster
Diffstat (limited to 'app-crypt/eobcanka/eobcanka-3.5.0.ebuild')
-rw-r--r--app-crypt/eobcanka/eobcanka-3.5.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-crypt/eobcanka/eobcanka-3.5.0.ebuild b/app-crypt/eobcanka/eobcanka-3.5.0.ebuild
new file mode 100644
index 0000000..ffa829a
--- /dev/null
+++ b/app-crypt/eobcanka/eobcanka-3.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker xdg
+
+DESCRIPTION="Applications and libraries for the Czech eObcanka identity card."
+HOMEPAGE="https://info.identitaobcana.cz/eop"
+SRC_URI="https://info.identitaobcana.cz/download/eObcanka.deb -> ${PN}-${PV}.deb"
+
+LICENSE="Apache-2.0 LGPL-3 openssl eObcanka"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}"
+
+RDEPEND="
+ dev-qt/qtlocation
+ sys-apps/pcsc-lite
+ media-libs/libpng
+ x11-libs/libX11
+ x11-libs/gtk+:3
+ dev-libs/glib
+ x11-libs/libxcb
+ "
+
+src_unpack() {
+ unpack_deb "${A}"
+}
+
+src_install() {
+ cp -R "${WORKDIR}/usr" "${D}" || die "Installation failed"
+ cp -R "${WORKDIR}/opt" "${D}" || die "Installation failed"
+}