summaryrefslogtreecommitdiff
path: root/media-video/aravis/aravis-9999.ebuild
diff options
context:
space:
mode:
authorCtibor Brančík <ctibor@brancik.cz>2020-01-12 17:36:13 +0100
committerCtibor Brančík <ctibor@brancik.cz>2020-01-12 17:36:13 +0100
commitb341c97543ca64b160b4ece00f51a85bbba3d4a4 (patch)
tree7d78b4a873346ac36529854abcb7593a49d42285 /media-video/aravis/aravis-9999.ebuild
parent37e1361564c1a4048529d923039318f0f629c426 (diff)
downloadbrancik-overlay-b341c97543ca64b160b4ece00f51a85bbba3d4a4.tar.gz
brancik-overlay-b341c97543ca64b160b4ece00f51a85bbba3d4a4.tar.bz2
Revert "Remove media-video/aravis, ebuild exists in main portage tree"
This reverts commit 9653a96d3fe2127639129f862ab4d3b272f124d4.
Diffstat (limited to 'media-video/aravis/aravis-9999.ebuild')
-rw-r--r--media-video/aravis/aravis-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-video/aravis/aravis-9999.ebuild b/media-video/aravis/aravis-9999.ebuild
new file mode 100644
index 0000000..f9b754e
--- /dev/null
+++ b/media-video/aravis/aravis-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit git-2 autotools
+
+KEYWORDS="~amd64 ~x86"
+
+EGIT_REPO_URI="https://github.com/AravisProject/aravis.git"
+
+DESCRIPTION="Library for video acquisition using Genicam cameras"
+
+HOMEPAGE="https://github.com/AravisProject/aravis"
+
+LICENSE="LGPL-2"
+
+SLOT="0"
+
+IUSE="X gstreamer"
+
+GST_DEPEND="media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10"
+
+RDEPEND=">=dev-libs/glib-2.22
+ dev-libs/libxml2
+ X? (
+ >=x11-libs/gtk+-2.12:2
+ ${GST_DEPEND}
+ media-libs/gst-plugins-base:0.10
+ media-plugins/gst-plugins-xvideo:0.10
+ )
+ gstreamer? ( ${GST_DEPEND} )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/gobject-introspection"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+src_prepare() {
+ eautoreconf
+}