summaryrefslogtreecommitdiff
path: root/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild
diff options
context:
space:
mode:
authorCtibor <ctibor.brancik@seznam.cz>2015-01-30 20:38:47 +0100
committerCtibor <ctibor.brancik@seznam.cz>2015-01-30 20:38:47 +0100
commit8c63f5900555fbb250d00d7dd0dba6d4593fbed3 (patch)
tree0c3704c9d44f9f6a5a5daf9b0b6100712158cd7e /sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild
parentefe5d573092658a1fb6c9c41dfe41a3983a98450 (diff)
downloadbrancik-overlay-8c63f5900555fbb250d00d7dd0dba6d4593fbed3.tar.gz
brancik-overlay-8c63f5900555fbb250d00d7dd0dba6d4593fbed3.tar.bz2
Removed unnecessary ebuilds that have been added to the main tree already or are not needed anymore.
Diffstat (limited to 'sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild')
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild
deleted file mode 100644
index 79d1097..0000000
--- a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130815.ebuild,v 1.1 2013/08/15 18:29:55 xmw Exp $
-
-EAPI=5
-
-inherit readme.gentoo
-
-DESCRIPTION="Raspberry PI boot loader and firmware"
-HOMEPAGE="https://github.com/raspberrypi/firmware"
-SRC_URI=""
-for my_src_uri in bootcode.bin fixup{,_cd,_x}.dat start{,_cd,_x}.elf ; do
- SRC_URI="${SRC_URI} https://raw.githubusercontent.com/raspberrypi/firmware/master/boot/${my_src_uri} -> ${PN}-${my_src_uri}"
-done
-
-LICENSE="GPL-2 raspberrypi-videocore-bin"
-SLOT="0"
-KEYWORDS="~arm -*"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S=${WORKDIR}
-
-RESTRICT="binchecks strip"
-
-src_unpack() { :; }
-
-pkg_preinst() {
- if [ -z "${REPLACING_VERSIONS}" ] ; then
- local msg=""
- if [ -e "${D}"/boot/cmdline.txt -a -e /boot/cmdline.txt ] ; then
- msg+="/boot/cmdline.txt "
- fi
- if [ -e "${D}"/boot/config.txt -a -e /boot/config.txt ] ; then
- msg+="/boot/config.txt "
- fi
- if [ -n "${msg}" ] ; then
- msg="This package installs following files: ${msg}."
- msg="${msg} Please remove(backup) your copies durning install"
- msg="${msg} and merge settings afterwards."
- msg="${msg} Further updates will be CONFIG_PROTECTed."
- die "${msg}"
- fi
- fi
-}
-
-src_install() {
- insinto /boot
- local a
- for a in ${A} ; do
- newins "${DISTDIR}"/${a} ${a#${PN}-}
- done
- newins "${FILESDIR}"/${PN}-0_p20130711-config.txt config.txt
- newins "${FILESDIR}"/${PN}-0_p20130711-cmdline.txt cmdline.txt
- newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
- readme.gentoo_create_doc
-}
-
-DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"