summaryrefslogtreecommitdiff
path: root/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild
diff options
context:
space:
mode:
authorCtibor <ctibor.brancik@seznam.cz>2014-08-07 18:24:04 +0200
committerCtibor <ctibor.brancik@seznam.cz>2014-08-07 18:24:04 +0200
commitdaa0052c8cd7f3506b0e785be0ced73838c9e40a (patch)
treec4b28ae25647c9f5e2a1ff1789744ba118df4296 /sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild
parent9ed73ad933069d312f6c19bdd35876fccb9b04f2 (diff)
downloadbrancik-overlay-daa0052c8cd7f3506b0e785be0ced73838c9e40a.tar.gz
brancik-overlay-daa0052c8cd7f3506b0e785be0ced73838c9e40a.tar.bz2
Reworked =sys-boot/raspberrypi-firmware-9999 to remove file colisions.
Diffstat (limited to 'sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild')
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild128
1 files changed, 51 insertions, 77 deletions
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild
index 2b88c9c..79d1097 100644
--- a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild
+++ b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild
@@ -1,87 +1,61 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130815.ebuild,v 1.1 2013/08/15 18:29:55 xmw Exp $
-EAPI="4"
+EAPI=5
-DESCRIPTION="Proprietary libraries for the Broadcom BCM2835 SoC (including the Raspberry Pi computer)"
-HOMEPAGE="http://www.broadcom.com/ http://www.raspberrypi.org/"
+inherit readme.gentoo
-inherit git-2
-
-EGIT_REPO_URI="git://github.com/raspberrypi/firmware.git"
-EGIT_PROJECT="raspberrypi-firmware.git"
+DESCRIPTION="Raspberry PI boot loader and firmware"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+SRC_URI=""
+for my_src_uri in bootcode.bin fixup{,_cd,_x}.dat start{,_cd,_x}.elf ; do
+ SRC_URI="${SRC_URI} https://raw.githubusercontent.com/raspberrypi/firmware/master/boot/${my_src_uri} -> ${PN}-${my_src_uri}"
+done
+LICENSE="GPL-2 raspberrypi-videocore-bin"
SLOT="0"
-
-KEYWORDS="arm"
-
-# TODO: Make the samples actually optional
-IUSE="X +hardfp +samples"
-
-DEPEND="!media-libs/bcm2835-libs
- X? ( || ( <media-libs/mesa-8.0[-egl,-gles,-openvg] >=media-libs/mesa-8.0[-egl,-gles1,-gles2,-openvg] ) )"
-RDEPEND="${DEPEND}"
-
-RESTRICT="mirror strip test"
-
-# QA Silencing
-QA_TEXTRELS="
- opt/vc/lib/libbcm_host.so
- opt/vc/lib/libGLESv2.so
- opt/vc/lib/libluammal.so
- opt/vc/lib/libmmal.so
- opt/vc/lib/libEGL.so
- opt/vc/lib/libopenmaxil.so
-"
-
-QA_EXECSTACK="
- opt/vc/bin/vchiq_test
- opt/vc/bin/vcdbg
- opt/vc/bin/vcmemmap
- opt/vc/bin/tvservice
- opt/vc/bin/edidparser
- opt/vc/bin/vcgencmd
- opt/vc/sbin/vcfiled
-"
-
-src_install() {
- if use hardfp; then
- cd "${S}/hardfp/opt/vc"
- else
- cd "${S}/opt/vc"
+KEYWORDS="~arm -*"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+RESTRICT="binchecks strip"
+
+src_unpack() { :; }
+
+pkg_preinst() {
+ if [ -z "${REPLACING_VERSIONS}" ] ; then
+ local msg=""
+ if [ -e "${D}"/boot/cmdline.txt -a -e /boot/cmdline.txt ] ; then
+ msg+="/boot/cmdline.txt "
+ fi
+ if [ -e "${D}"/boot/config.txt -a -e /boot/config.txt ] ; then
+ msg+="/boot/config.txt "
+ fi
+ if [ -n "${msg}" ] ; then
+ msg="This package installs following files: ${msg}."
+ msg="${msg} Please remove(backup) your copies durning install"
+ msg="${msg} and merge settings afterwards."
+ msg="${msg} Further updates will be CONFIG_PROTECTed."
+ die "${msg}"
+ fi
fi
- insinto /opt/vc
- doins -r include lib
- use samples && doins -r src
- exeinto /opt/vc/bin
- doexe bin/*
- exeinto /opt/vc/sbin
- doexe sbin/*
-
- dodoc "LICENCE"
+}
- # Create symlinks for header files
- local vcos_include_dir
- vcos_include_dir="/opt/vc/include/interface/vcos"
- local vcos_includes
- vcos_includes="vcos_futex_mutex.h"
- vcos_includes+=" vcos_platform.h"
- vcos_includes+=" vcos_platform_types.h"
- for vcos_include in ${vcos_includes}; do
- dosym "${vcos_include_dir}/pthreads/${vcos_include}" \
- "${vcos_include_dir}/${vcos_include}"
- done
-
- local bcm_includes
- bcm_includes="bcm_host.h"
- bcm_includes+=" EGL GLES GLES2 IL"
- bcm_includes+=" interface KHR"
- bcm_includes+=" vcinclude VG"
- for bcm_include in ${bcm_includes}; do
- dosym /opt/vc/include/${bcm_include} /usr/include/${bcm_include}
+src_install() {
+ insinto /boot
+ local a
+ for a in ${A} ; do
+ newins "${DISTDIR}"/${a} ${a#${PN}-}
done
+ newins "${FILESDIR}"/${PN}-0_p20130711-config.txt config.txt
+ newins "${FILESDIR}"/${PN}-0_p20130711-cmdline.txt cmdline.txt
+ newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
+ readme.gentoo_create_doc
+}
- insinto /etc/env.d
- newins "${FILESDIR}/${PN}.envd" "02${PN}"
-} \ No newline at end of file
+DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"