summaryrefslogtreecommitdiff
path: root/app-crypt/eobcanka/eobcanka-3.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/eobcanka/eobcanka-3.2.0.ebuild')
-rw-r--r--app-crypt/eobcanka/eobcanka-3.2.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-crypt/eobcanka/eobcanka-3.2.0.ebuild b/app-crypt/eobcanka/eobcanka-3.2.0.ebuild
new file mode 100644
index 0000000..ce021a2
--- /dev/null
+++ b/app-crypt/eobcanka/eobcanka-3.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker xdg
+
+DESCRIPTION="Applications and libraries for the Czech eObcanka identity card."
+HOMEPAGE="https://info.eidentita.cz/eop"
+SRC_URI="https://info.eidentita.cz/download/eObcanka.deb -> ${PN}-${PV}.deb"
+
+LICENSE="Apache-2.0 LGPL-3 openssl eObcanka"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ cp -R "${WORKDIR}/usr" "${D}" || die "Installation failed"
+ cp -R "${WORKDIR}/opt" "${D}" || die "Installation failed"
+}