summaryrefslogtreecommitdiff
path: root/kde-misc/publictransport/publictransport-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/publictransport/publictransport-9999.ebuild')
-rwxr-xr-xkde-misc/publictransport/publictransport-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-misc/publictransport/publictransport-9999.ebuild b/kde-misc/publictransport/publictransport-9999.ebuild
new file mode 100755
index 0000000..584bcc1
--- /dev/null
+++ b/kde-misc/publictransport/publictransport-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit kde4-base
+
+DESCRIPTION="KDE plasmoid. This applet shows a departure board for a given stop."
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=106175"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND="
+"
+
+DEPEND="dev-vcs/git"
+
+
+### Variables
+MY_WORKDIR="${WORKDIR}"/"${P}"
+S="${MY_WORKDIR}"
+
+src_unpack() {
+ #unpack ${A}
+ git clone git://anongit.kde.org/publictransport ${S}
+ cp "${FILESDIR}/CMakeLists.txt" ${S}/
+ cp "${FILESDIR}/CMakeLists-accessor.txt" "${S}/engine/accessorInfos/CMakeLists.txt"
+ ln -s "${S}/libpublictransporthelper" "${S}/publictransporthelper"
+}
+
+MAKEOPTS="-j1"
+