summaryrefslogtreecommitdiff
path: root/media-video/aravis/aravis-0.5.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/aravis/aravis-0.5.11.ebuild')
-rw-r--r--media-video/aravis/aravis-0.5.11.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-video/aravis/aravis-0.5.11.ebuild b/media-video/aravis/aravis-0.5.11.ebuild
new file mode 100644
index 0000000..8ea305e
--- /dev/null
+++ b/media-video/aravis/aravis-0.5.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools versionator
+
+KEYWORDS="~amd64 ~x86"
+
+MY_PV="$(replace_all_version_separators '_')"
+
+MY_PN="${PN^^}"
+
+SRC_URI="https://github.com/AravisProject/${PN}/archive/${MY_PN}_${MY_PV}.tar.gz"
+
+DESCRIPTION="Library for video acquisition using Genicam cameras"
+
+HOMEPAGE="https://github.com/AravisProject/aravis"
+
+LICENSE="LGPL-2"
+
+SLOT="0"
+
+IUSE="X gstreamer"
+
+GST_DEPEND="media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10"
+
+RDEPEND=">=dev-libs/glib-2.22
+ dev-libs/libxml2
+ X? (
+ >=x11-libs/gtk+-2.12:2
+ ${GST_DEPEND}
+ media-libs/gst-plugins-base:0.10
+ media-plugins/gst-plugins-xvideo:0.10
+ )
+ gstreamer? ( ${GST_DEPEND} )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/gobject-introspection"
+
+S="${WORKDIR}/${PN}-${MY_PN}_${MY_PV}"
+
+src_prepare() {
+ eautoreconf
+}