summaryrefslogtreecommitdiff
path: root/sci-astronomy/astrometry/astrometry-0.52.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/astrometry/astrometry-0.52.ebuild')
-rw-r--r--sci-astronomy/astrometry/astrometry-0.52.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/sci-astronomy/astrometry/astrometry-0.52.ebuild b/sci-astronomy/astrometry/astrometry-0.52.ebuild
index 44a87fd..d42bfb5 100644
--- a/sci-astronomy/astrometry/astrometry-0.52.ebuild
+++ b/sci-astronomy/astrometry/astrometry-0.52.ebuild
@@ -37,17 +37,13 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MYP}"
-src_prepare() {
- epatch \
- "${FILESDIR}"/0.43-as-needed.patch \
- "${FILESDIR}"/0.43-respect-user-flags.patch \
- "${FILESDIR}"/0.43-system-libs.patch
+PATCHES=( "${FILESDIR}/0.52-as-needed.patch" "${FILESDIR}/0.52-respect-user-flags.patch" )
+src_prepare() {
python_fix_shebang "${S}"
sed "s|python setup-util.py|${EPYTHON} setup-util.py|" "${S}"/util/Makefile -i || die
sed "s|python setup.py|${EPYTHON} setup.py|" "${S}"/{libkd,sdss,blind}/Makefile -i || die
sed "s|python -c|${EPYTHON} -c|" "${S}"/blind/Makefile -i || die
- sed "s|python <<EOF|${EPYTHON} <<EOF|" "${S}"/blind/simplexy.c -i || die
sed "s|python -V|${EPYTHON} -V|" "${S}"/Makefile -i || die
}
@@ -76,7 +72,7 @@ src_compile() {
src_install() {
# TODO: install in standard directories to respect FHS
- export INSTALL_DIR="${ED}"/usr/astrometry
+ export INSTALL_DIR="${ED}"/usr
emake install-core
use extra && emake -C blind install-extra