summaryrefslogtreecommitdiff
path: root/sci-astronomy/ccd/ccd-1.2.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/ccd/ccd-1.2.10.ebuild')
-rw-r--r--sci-astronomy/ccd/ccd-1.2.10.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sci-astronomy/ccd/ccd-1.2.10.ebuild b/sci-astronomy/ccd/ccd-1.2.10.ebuild
new file mode 100644
index 0000000..c7a19c4
--- /dev/null
+++ b/sci-astronomy/ccd/ccd-1.2.10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/indilib-0.7.2.ebuild,v 1.6 2011/10/30 15:47:38 ssuominen Exp $
+
+EAPI=5
+
+inherit qt4-r2
+
+DESCRIPTION="Simple astronomical CCD controller"
+HOMEPAGE="http://sourceforge.net/projects/cccd/"
+SRC_URI="http://downloads.sourceforge.net/project/cccd/${PN}/${PV}/${PN}-${PV}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ virtual/libusb:1
+ sys-apps/fxload
+ media-libs/libgphoto2
+ >=media-libs/libraw-0.9.1
+ media-libs/tiff:0
+ media-libs/lcms
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ || ( <sci-libs/indilib-driver-qhy-9999 >=sci-libs/libqhy-9999 )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}/ccd-1.2.9-fix_helper_scripts_paths.patch")
+
+src_compile() {
+ qt4-r2_src_compile
+ cd "${S}"/shutter_procs/
+ make
+ cd "${S}"
+}
+
+src_install() {
+ dobin ccd
+ exeinto /usr/libexec/ccd
+ doexe shutter_procs/shutter
+ doexe utils/qhy6reset.sh
+ doexe utils/qhy8reset.sh
+ doexe utils/qhy8lreset.sh
+ doexe utils/qhy9reset.sh
+ dodoc readme
+ dodoc readme.en
+ dodoc readme.ru
+}