summaryrefslogtreecommitdiff
path: root/sci-astronomy/ccd/ccd-1.2.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/ccd/ccd-1.2.9.ebuild')
-rw-r--r--sci-astronomy/ccd/ccd-1.2.9.ebuild36
1 files changed, 17 insertions, 19 deletions
diff --git a/sci-astronomy/ccd/ccd-1.2.9.ebuild b/sci-astronomy/ccd/ccd-1.2.9.ebuild
index 3e51a00..07b9591 100644
--- a/sci-astronomy/ccd/ccd-1.2.9.ebuild
+++ b/sci-astronomy/ccd/ccd-1.2.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/indilib-0.7.2.ebuild,v 1.6 2011/10/30 15:47:38 ssuominen Exp $
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
- dev-libs/libusb:1
+ virtual/libusb:1
sys-apps/fxload
media-libs/libgphoto2
>=media-libs/libraw-0.9.1
@@ -23,8 +23,7 @@ RDEPEND="
media-libs/lcms
dev-qt/qtcore:4
dev-qt/qtgui:4
- || ( <sci-libs/indilib-driver-qhy-9999 >=sci-libs/libqhy-9999 )
-"
+ || ( <sci-libs/indilib-driver-qhy-9999 >=sci-libs/libqhy-9999 )"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${PN}"
@@ -32,22 +31,21 @@ S="${WORKDIR}/${PN}"
PATCHES=( "${FILESDIR}/ccd-1.2.9-fix_helper_scripts_paths.patch")
src_compile() {
- qt4-r2_src_compile
- cd ${S}/shutter_procs/
- make
- cd ${S}
+ qt4-r2_src_compile
+ cd "${S}"/shutter_procs/
+ make
+ cd "${S}"
}
src_install() {
- dobin ccd
- exeinto /usr/libexec/ccd
- doexe shutter_procs/shutter
- doexe utils/qhy6reset.sh
- doexe utils/qhy8reset.sh
- doexe utils/qhy8lreset.sh
- doexe utils/qhy9reset.sh
- dodoc readme
- dodoc readme.en
- dodoc readme.ru
+ dobin ccd
+ exeinto /usr/libexec/ccd
+ doexe shutter_procs/shutter
+ doexe utils/qhy6reset.sh
+ doexe utils/qhy8reset.sh
+ doexe utils/qhy8lreset.sh
+ doexe utils/qhy9reset.sh
+ dodoc readme
+ dodoc readme.en
+ dodoc readme.ru
}
-