summaryrefslogtreecommitdiff
path: root/sci-libs/libsbig/libsbig-1.8.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libsbig/libsbig-1.8.3.ebuild')
-rw-r--r--sci-libs/libsbig/libsbig-1.8.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sci-libs/libsbig/libsbig-1.8.3.ebuild b/sci-libs/libsbig/libsbig-1.8.3.ebuild
new file mode 100644
index 0000000..9181b6d
--- /dev/null
+++ b/sci-libs/libsbig/libsbig-1.8.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_PN="indi"
+
+DESCRIPTION="Driver for the Santa Barbara Instruments Group line of CCDs & Filter Wheels"
+HOMEPAGE="http://indilib.org"
+SRC_URI="https://github.com/${MY_PN}lib/${MY_PN}-3rdparty/archive/v${PV}.tar.gz -> ${MY_PN}lib-3rdparty-${PV}.tar.gz"
+
+LICENSE="sbig"
+KEYWORDS="~amd64 ~x86"
+
+SLOT="0/1"
+
+RDEPEND="${DEPEND}
+ sys-apps/fxload"
+
+INDI_TARGET_DIRECTORY="${PN%%lib-driver-**}"
+
+S="${WORKDIR}/${MY_PN}-3rdparty-${PV}/${INDI_TARGET_DIRECTORY}"