summaryrefslogtreecommitdiff
path: root/sys-auth/poldi/poldi-0.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/poldi/poldi-0.4.1.ebuild')
-rw-r--r--sys-auth/poldi/poldi-0.4.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-auth/poldi/poldi-0.4.1.ebuild b/sys-auth/poldi/poldi-0.4.1.ebuild
new file mode 100644
index 0000000..e971f75
--- /dev/null
+++ b/sys-auth/poldi/poldi-0.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit pam
+
+DESCRIPTION="PAM module implementing authentication via OpenPGP smartcards"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/poldi/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="usb"
+
+DEPEND="dev-libs/libgcrypt
+ virtual/pam
+ >=dev-libs/libgpg-error-0.7
+ usb? ( >=dev-libs/libusb-0.1.10a )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/*.diff
+}
+
+src_install() {
+ default
+ dopammod "${S}"/src/pam/pam_poldi.so
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS
+ dodir /etc/poldi
+ cp "${FILESDIR}"/poldi.conf.example "${D}"/etc/poldi
+}